WP自动升级错误 http.php on line 1358解决方法

Apr 17th Sat, 2010/JiaJieChan/折腾/1,286 阅读/没有评论

错误原因:

  1. 博客数据库中的数据量太大,导致程序执行时间过长;
  2. 博客所使用的服务器设置做了限制,php.ini 中缺省的程序最长执行时间是 30 秒,程序若执行超过30秒,就会被系统终止。

 

解决办法:

        1. 打开wp-includeshttp.php文件

        2.在 <?php 下面插入以下代码:

           set_time_limit(300);   //0为无限制

声明: 本文采用 BY-NC-SA 协议进行许可. 转载请出示版权信息.
  1. 本文目前尚无任何评论.
  1. 本文目前尚无任何 trackbacks 和 pingbacks.
支持使用Gravatar头像

JiaJieChan提醒您: 要回复某人的评论,请将鼠标移动到那条评论,评论右边就会出现Replay字样(一定是要鼠标指针中的评论),在评论框中出现的的后面下一行填写评论提交即可.被回复者将收到邮件通知噢; 要是想直接对本文评论请直接在评论框留言即可,然后点提交.